On Wed, 14 May 2014 05:04:45 GMT, Sebastiaan Koppe wrote:

For anyone wondering how to get start-stop-daemon working with vibenews (especially serving static files from the right path)

do not, like I did, forget to add the chdir argument to start-stop-daemon.

Suppose vibenews is in /opt/vibenews:

start-stop-daemon --chuid ubuntu --background --chdir /opt/vibenews --oknodo --start --exec vibenews

Else vibenews will start serving static files from the absolute path of /public

I'm sorry to ask since it's kinda offtopic and bump an old thread, but did you figured out how to stop started vibe.d instance? I tried to make it as with nginx, by adding --pidfile option, based on this tutorial

start-stop-daemon --start --quiet --background --pidfile $PIDFILE --exec $DAEMON

Daemon starts indeed, I can see it with ps aux and it accepts connections, but .pid file never created, so I'm not surprised

start-stop-daemon --stop --quiet --pidfile $PIDFILE <...>

doesn't work. Of course I can just kill process by id from ps aux list but it looks annoying.