Am 19.02.2015 um 18:39 schrieb Luís Marques:

I've checked that vibenews almost compiles with vibe.d 0.7.20 (the one in package.json, which is not chosen because the repo does not have a dub.selections.json), except that version of vibe.d does not compile with the latest DMD due to a collision. I've tried to understand the errors that start happening with vibe.d 0.7.21, even doing a diff between 0.7.20 and ~master of bson.d, but I didn't yet understand the source of the error. I hope that helps a little bit.

I've pushed an update to the latest versions of the dependencies now.
The errors were caused by the wrong version of userman being selected
due to the bug below. To fix this, the code is now properly updated.

However, at least on Windows, I'm getting a strange crash caused by a
corrupted stack. I'll need to investigate this further.

BTW: I would argue that if dub.json says foo version "==1.0.0" and dub.selections.json says version "1.1.0" than dub.json should either win (and replace dub.selections.json with the older version) or dub should just complain, instead of silently going with dub.selections.json.

In this case, something like the following message should appear:
Selected package X 1.1.0 does not match the dependency specification in
package Y (1.0.0). Need to "dub upgrade"?

However, there was a bug where "~>1.0.0" would match "1.1.0" that I've
fixed now.