Thanks Sönke, it is working now. :)

On Mon, 27 Jan 2014 15:33:41 GMT, Sönke Ludwig wrote:

On Tue, 21 Jan 2014 18:35:07 GMT, Daniel Vieira wrote:

Hello fellows, this is my first post, and so I would like to thanks for Vibe.d project.

I already run a Vibe server on my mac flawlessly.

Now I tried to run with FreeBSD and I have this output error message, I'll post here in the hope someone can help:

$ dub build
Checking dependencies in '/usr/home/daniel/Developer/CEPServer'
Target is up to date. Using existing build in /home/daniel/.dub/packages/vibe-d-master/.dub/build/libevent-debug-x86-dmd-8A155FF40318D806C8EFD477F37AAB82/. Use --force to force a rebuild.
Target is up to date. Using existing build in /home/daniel/.dub/packages/dpq2-master/.dub/build/static-debug-x86-dmd-78D22F1490EC6647A4AB379A175DB529/. Use --force to force a rebuild.
Building cepserver configuration "application", build type debug.
Warning: -version=VibeDefaultMain will be required in the future to use vibe.d's default main(). Please update your build scripts.
/usr/bin/ld: Dwarf Error: found dwarf version '3', this reader only handles version 2 information.
.dub/build/application-debug-x86-dmd-CB886840CFAA36435C7579C518E36D98/cepserver.o:(.data.D94TypeInfoS3std9container54T5ArrayTS4vibe4core7drivers9libevent212TimeoutEntryZ5Array7Payload6initZ+0x30): undefined reference to _D3std9container54__T5ArrayTS4vibe4core7drivers9libevent212TimeoutEntryZ5Array7Payload10__postblitMFZv'<br>.dub/build/application-debug-x86-dmd-CB886840CFAA36435C7579C518E36D98/cepserver.o:(.data._D188TypeInfo_S3std9container144__T10BinaryHeapTS3std9container54__T5ArrayTS4vibe4core7drivers9libevent212TimeoutEntryZ5ArrayVAyaa21_612e74696d656f7574203e20622e74696d656f7574Z10BinaryHeap4Data6__initZ+0x30): undefined reference to D3std9container144T10BinaryHeapTS3std9container54T5ArrayTS4vibe4core7drivers9libevent212TimeoutEntryZ5ArrayVAyaa21612e74696d656f7574203e20622e74696d656f7574Z10BinaryHeap4Data15__fieldPostBlitMFZv'
--- errorlevel 1
FAIL .dub/build/application-debug-x86-dmd-CB886840CFAA36435C7579C518E36D98 cepserver executable
Error executing command build: Link command failed with exit code 1

It seems that the problem relates to libevent, but I don't have a clue how to solve this.

I've tried to revive my FreeBSD CI instance some time ago and also had some serious issues with libevent and the linker (that I never solved due to serious time constraints). But in this case it looks like an instance of DMD #12010 resp. vibe.d #458. Kenji Hara has made a light-speed fix, so hopefully the next DMD 2.065 beta (or final version) should work.