On Mon, 11 Mar 2013 19:38:17 GMT, Sönke Ludwig wrote:

On Mon, 11 Mar 2013 14:18:54 GMT, zhaopuming wrote:

Hi:

I was trying to use dub-0.9.11-linux-x8664.gz, but when it is extracted, there is a dub-0.9.11-linux-x8664 file which is not executable.
I use chmod +x, but it still cannot execute.

I can't build it in my desktop either. I'm in Ubuntu 12.10 x8664, and I've installed `apt-get install libcurl4-openssl-dev`,<br>but when I run './build', it still complaints about curlglobal_init and many other functions not defined.

Can you shed some light on this issue?

While I was writing an answer, I decided to do some research instead and found the cause: https://bugs.launchpad.net/ubuntu/+source/curl/+bug/1001576

I've added a workaround in the latest git master version and building should work fine now.

Thanks for the quick look :-)

Now the build is fine, and I get a dub file. But when I run the dub, it still says about curlglobalinit and many other functions not defined.

But it's strange that the executable didn't run. I have the same system here and there it works fine. Did it print any specific error message?

no specific error message, just says (I've install the Chinese language pack in Ubuntu):

"bash: ./dub-0.9.7-linux-x86_64: 无法执行二进制文件"

translates to english it is:

"bash: ./dub-0.9.7-linux-x86_64: binaries not executable"