Noticed your reply way to late, thanks for the help.

On Sat, 15 Jun 2013 18:59:45 +0200, Sönke Ludwig wrote:

Am 09.06.2013 14:55, schrieb maarten:

On Sun, 09 Jun 2013 11:43:20 GMT, maarten wrote:

Funny, I get the same errors when compiling vibe using dub.
I'm on arch linux, using dub-git and dmd 2.063.
The errors I'm getting are :
../../../../.dub/packages/vibe-d-0.7.15/source/vibe/vpm/installation.d(35): Warning: const field with initializer should be static, gshared, or an enum
../../../../.dub/packages/vibe-d-0.7.15/source/vibe/core/file.d(60): Warning: explicit element-wise assignment templ[16LU..
dollar - 1LU] = (suffix)[] is better than templ[16LU..__dollar - 1LU] = suffix

Should I downgrade dmd?

Ok, now using ~master (which requires the added dependency of libevent, libssl,.. at master too?)

Having to add libevent etc. shouldn't be required. I need to look into
that. What error messages did you get in this case?

Running dub now runs into the unpleasant:
/usr/bin/ld: cannot find -lev
collect2: error: ld returned 1 exit status
--- errorlevel 1
Error: Link command failed with exit code 1

This one needs a change in the package description format. Currently all
dependencies are included for any configuration (in this case libev,
although the libevent driver is used). I'll change the "dependencies"
field to be allowed inside "configurations" entries to avoid this.

Yet /usr/lib/ and /usr/lib/libevent.a do exist.
I created symbolic links to and libev.a and it compiled :D

Now it only gives a warning:
Listening for HTTP requests on :::2013
Failed to listen on

But seems to work (the test text is displayed)

This is normal depending on the operating system when IPv6 is enabled.
The default HttpServerSettings.bindAddresses field has both, "::" and
"" specified, but some systems automatically forward "" to
"::", so that "" is already implicitly bound and will fail to be
bound again explicitly. Setting HttpServerSettings.bindAddresses to
just ["::"] should silence that false error.