On Wed, 29 May 2013 19:20:25 GMT, Øivind Loe wrote:

On Wed, 29 May 2013 19:05:49 GMT, Sönke Ludwig wrote:

On Wed, 29 May 2013 15:36:50 GMT, Øivind Loe wrote:

Hmm. If so, could you post this, as I don't have the full picture here?

Also, I am actually building everything from source. I already have libphobos2.so

ls /usr/lib/x86_64-linux-gnu/ | grep phobos

I tried to delete the .0.63 ones, but when I run "sudo ldconfig", libphobos2.so.0.63 keeps coming back. If I try to build and run dub without the .0.63 ones there, I get this error:

dub: error while loading shared libraries: libphobos2.so.0.63: cannot open shared object file: No such file or directory

Maybe removing all the .so files helps, so that it has to pick up the static one?

I'll have a look and will try to reproduce it when I get some time in the coming days if it still doesn't work by then.

Nope. Didn't work removeing all of them. It still complains about not finding "libphobos2.so.0.63".

Thanks for looking into it.

Works now! :)