I am struggling currently to understand the way this is supposed to work.

Let's say I have a widget that I want to allow fetching and setting,
with registerWebInterface.

class WidgetInterface
{

void getWidget(int id);

}

This works awesome. I go to my web page, route of widget?id=1 and it works.

But then I want to update a widget:

void updateWidget(int id, string name)

Unfortunately, the route here, is still widget. Yes, it uses a different
method. But I have a dilemma here. I like the name "update", it's a good
verb for this method. However, vibe is making me either use UDA to "work
around" this limitation, or find some other nice term to go between
update and widget that reads well both with and without the method
prefix (I like my routes to be self explanatory).

For add, you can do addNewWidget, and newwidget seems reasonable,
because new is somewhat describing a "verb" even though its CS-related.
I can't think of something similar for update. updateExistingWidget
translates to existing
widget, which doesn't convey the action very
well. And there are multiple actions you can do on an existing widget.

Is there a reason we can't specify that the verb should remain in the
route name when registering an interface? Am I missing a better way to
do this? Are there best practices on this somewhere?

-Steve