On Sun, 11 Aug 2013 11:03:26 +0200, Sönke Ludwig wrote:

Am 08.08.2013 19:42, schrieb Craig Dillabaugh:

On Wed, 07 Aug 2013 16:36:31 GMT, Craig Dillabaugh wrote:

I recently tried to install DUB on OpenSuse 12.2, but ran into problems with it linking with libcurl and was hoping to get some help on getting DUB up on running.

My first attempt was to download the dub binary from the RS website. When I attempted to run dub I get the following error:

dub: error while loading shared libraries: libcurl.so.4: cannot open shared object file: No such file or directory

However, libcurl is right there in /usr/lib64 (which is in the linker path according to /etc/ld.so.conf):

/usr/lib64$ ls -l libcurl*


Any ideas on what I should do next to try and fix this.

Well I still haven't been able to build DUB from source, but I have solved my problem of getting a working copy of DUB, so I figured I should report back.

I had downloaded the 32bit version of DUB on my 64-bit OpenSuse install, which is undoubtedly why I had linking issues. I downloaded the proper binary ( dub-0.9.17-linux-x86_64.tar.gz ) and now everything works perfectly.

On the positive side, since I haven't had any replies, I hopefully haven't wasted too many peoples time.


I can't say what exactly goes wrong there, but one possible thing to try
would be to replace the $LIBS variable in build.sh:34 with
"-defaultlib=libphobos2.so" to link against the shared library version
of Phobos, which should already be linked against libcurl. I'll set up a
SuSE VM at some point, but that will have to wait a little.

I changed the lines in question to:

echo Running $DC...
$DC -ofbin/dub -g -debug -w -Isource $* -defaultlib=libphobos2.so @build-files.txt

and still get the same errors. If I can find some free time I will see if I can get it
to compile and post back here.